Prins VSI1 CNG Timing Optimizer (PTO) - kein RPM Signal

Diskutiere Prins VSI1 CNG Timing Optimizer (PTO) - kein RPM Signal im Prins Forum im Bereich Autogas Anlagen; Hallo zusammen, ich habe einen Volvo V70 III 2.5FT CNG mit einer Prins VSI 1 Anlage. Seit kurzem kam es ab und zu beim Starten vor, dass keine...

  1. rix1

    rix1 AutoGasDazugehöriger

    Dabei seit:
    27.02.2021
    Beiträge:
    38
    Zustimmungen:
    10
    Hallo zusammen,
    ich habe einen Volvo V70 III 2.5FT CNG mit einer Prins VSI 1 Anlage.
    Seit kurzem kam es ab und zu beim Starten vor, dass keine Drehzahl auf dem Tacho angezeigt wurde.
    Hatte auch im ECM Modul den Fehlercode ECM-P033600 Kurbelwellensignal.
    Daraufhin habe ich einen neuen Kurbelwellensensor eingebaut (Erstausrüster via Skandix).

    Die Drehzahl wird jetzt immer sauber im Tacho angezeigt, allerdings schaltet die Prins VSI nicht mehr auf CNG um, da anscheinend kein RPM Signal auf der 40er Leitung kommt. Habe das via Bexprins Pro nachgeschaut; auch Veränderung der RPM Flank auf absteigend oder beide hat nichts gebracht.
    Ich habe mir daraufhin mal die gesamte Verkabelung mithilfe des Installationshandbuchs angeschaut:
    (Google -> "prins vsi 1 installation manual"; erster Treffer)
    Bei mir ist noch ein "Prins Timing Optimizer (PTO)" verbaut; siehe Seite 33 PTO. Auf Seite 71 ist die sonstige CNG Verkabelung zu sehen.

    Man sieht dort, dass das induktive Signal vom Kurbelwellensensor in den PTO geht (C3 + und B3 -) und dann auf anderen Anschlüssen (C1+ und B1+) wieder heraus und zum ECM weitergeleitet wird. Das PTO gibt auf A3 das RPM Signal an die 40er Leitung vom VSI1. Neben Versorgungsspannung geht noch das Injector Mod. Command und MAP in das PTO.

    Ich habe sämtliche Kabel durchgemessen, kann die 120Ohm vom Kurbelwellensensor sowohl am PTO Eingang als auch Ausgang messen. Der Sensor und die Kabel sind also in Ordnung.

    Kann es sein, dass der PTO ausgehend vom Injec. Mod. Signal und MAP das Kurbelwellensignal unterbricht/verändert? Und das mein Kurbelwellensensor gar nicht defekt war, sondern mein PTO einen Defekt hat, und aktuell das Signal nur noch zum ECM durchschleift, aber nichts mehr verändert? Und das deswegen das induktive Signal auch nicht mehr in ein Rechtecksignal an die 40er Leitung an das VSI weitergeleitet wird?

    Vielleicht gibt es hier ja einen Prins VSI CNG Experten, der sich mit dem PTO auskennt.

    Was ich jetzt noch versuchen würde:
    -Die 40er Leitung mal direkt auf einen Hall-Sensor klemmen (z.B. Nockenwellensensor) oder einfach direkt 12V drauf geben? (Passt das, normalerweise ist ja +5V max Spannung?); Wenn dann ein RPM Signal angezeigt wird, dann weiß ich, dass der VSI Computer noch OK sein sollte

    Danke VG
     
  2. Anzeige

  3. rix1

    rix1 AutoGasDazugehöriger

    Dabei seit:
    27.02.2021
    Beiträge:
    38
    Zustimmungen:
    10
    Hallo nochmal,
    kurzen Nachtrag, habe mir jetzt ein 5V Akkupack gebaut um das RPM Signal auf dem Prins VSI zu testen, einfach um auf Nummer sicher zu gehen.
    Hab dann in Bexprins den Logger gestartet und einfach ein paar mal auf die 40er Leitung gegangen.
    Wie man sieht, funktioniert die VSI und der RPM Eingang einwandfrei
    2023-07-08 14_00_34-2023-07-08 13_27_50-Settings.png ‎- Photos.png .
    Also ist bei mir tatsächlich das PTO Modul defekt, ich schaue mich jetzt nach einem neuen/Gebrauchtteil um.
    Ansonsten klemme ich einfach direkt einen Nockenwellensensor auf die 40er Leitung und nutze die Prins ohne das PTO Modul.
    Mir ist nicht ganz ersichtlich, wie das ganze überhaupt zusammenspielt bzw. nützlich sein soll.
    Das Induktivsignal wird offenbar modifiziert um den ECM eine andere Position des Schwungrades mitzuteilen? Finde leider auch fast nichts über dieses Modul von Prins..
     
  4. 540V8

    540V8 Meister der Beiträge
    Moderator

    Dabei seit:
    23.11.2008
    Beiträge:
    15.698
    Zustimmungen:
    1.247
    Das Drehzahlmodul ist bei der Prins dann erforderlich, wenn das Signal z.b. Zündspule zu stark ist. Damit schießt man das Gassteuergerät ab.
    Normal nimmt man auch sofern Vorhanden das Nockenwellensignal.
     
  5. rix1

    rix1 AutoGasDazugehöriger

    Dabei seit:
    27.02.2021
    Beiträge:
    38
    Zustimmungen:
    10
    @540V8
    Ich glaube du meinst das 4 adrige RPM Modul von Prins, Bez. 091/020001/A?

    Das CNG Prins Timing Optimizer PTO Modul (095/70045), was bei mir mit CNG verbaut ist, ist aber dieses hier:
    2023-07-09 15_07_12-prins timing optimizer - Google Search.png

    Die Verkabelung sieht so aus, Seite 33 vom Installation Handbuch.
    pn.png

    Habe mal den Kurbelwellensensor gelb markiert. Hall-Sensor/Nockenwelle ist bei mir nicht an C5 angeschlossen/durchgeschleift.
     
  6. 540V8

    540V8 Meister der Beiträge
    Moderator

    Dabei seit:
    23.11.2008
    Beiträge:
    15.698
    Zustimmungen:
    1.247
    Timing Optimizer ist für die Zündung bei CNG Fahrzeuge zur Optimierung gedacht. ob der für die Generierung des Drehzahlsignals zuständig ist, kann ich nicht sagen . Hab mit CNG zu wenig am Hut.
     
  7. rix1

    rix1 AutoGasDazugehöriger

    Dabei seit:
    27.02.2021
    Beiträge:
    38
    Zustimmungen:
    10
    Danke, ich frage mich halt, wie das Ding eigentlich funktioniert.
    Interessant ist, dass das Modul "in Serie" zum ECM bzgl. des RPM Signals geschaltet wird, und nicht parallel wie z.B. MAP oder Temperatursensor. Deshalb kann ich mir schon vorstellen, dass das RPM Signal verändert wird.

    Nun ja, ich habe jetzt einen gebrauchten PTO gekauft, baue ihn nächste Woche mal ein und schaue dann weiter.
     
  8. #7 V8gaser, 10.07.2023
    V8gaser

    V8gaser Meister der Beiträge

    Dabei seit:
    14.04.2007
    Beiträge:
    12.606
    Zustimmungen:
    1.038
    Es werden halt beide Signale- Nockenwellen und Kurbelwellensensor durch den PTO geschleift, und der verändert den ZEITPUNKT so für die Benzin dme, das die entsprechend dem CNG Betrieb früher zündet. Direkt mit dem Drehzahlsignal ansich hat der nix zu tun -das Drehzahlkabel der Anlage wird gesondert angeschlossen.
    Das Teil muss dann auch über den eigenen Diagnosestecker mittels der extra PTO Software programmiert werden
     
  9. #8 V8gaser, 10.07.2023
    V8gaser

    V8gaser Meister der Beiträge

    Dabei seit:
    14.04.2007
    Beiträge:
    12.606
    Zustimmungen:
    1.038
    Die Programmierung von dem Dingens kann man übrigens nicht selber machen. Mit der PTO Software (so man sie überhaupt bekommt) lässt sich nur schauen ob der funktioniert.
    Programmieren, kann den der Importeur, zB die Fa EKo Gas (an Herrn Dallmann wenden wenns wär) weil das Fz spezifisch erfolgen muss, also mit Fahrgestellnummer usw.
     
  10. rix1

    rix1 AutoGasDazugehöriger

    Dabei seit:
    27.02.2021
    Beiträge:
    38
    Zustimmungen:
    10
    Hallo @V8gaser,
    danke!
    Ich habe bei mir den kompletten Kabelstrang auseinander genommen und alle Stecker geprüft, an dem PTO selbst ist nur B3 und C3 vom Kurbelwellensensor belegt. Der Nockenwellensensor (B5 bzw. C5) ist nicht angeschlossen, diese Pins sind nicht belegt.
    Das lila-weiße RPM Kabel geht von A3 vom PTO zu Pin 40 auf die Prins CM.
    Das lila-weiße RPM Kabel ist runter zum Motor nicht vorhanden, also gehe ich davon aus, dass bei mir kein gesondertes Drehzahlkabel vorhanden ist.

    Ja, ich habe bei mir noch einen grauen PTO Diagnoseanschluss, hatte auch mal versucht über die RS232 Schnittstelle via Bexprins sowie hterm an Fehlercodes zu gelangen, aber das PTO scheint tot zu sein. Gibt gar nichts von sich...

    Danke für den Tipp mit Eko-Gas und Herrn Dallmann in Leipzig. Hatte auch mal bei Car-Gas (Prins) in Wabern angerufen, der Mitarbeiter kannte sich leider mit dem PTO nicht so gut aus und hat mir Herrn Sommerfeld in Düsseldorf als CNG Experten genannt. Liegt natürlich beides nicht um die Ecke hier von München aus, da wärst du in Ergoldsbach natürlich viel näher...

    Ich warte jetzt erstmal ab, bis das gebrauchte PTO kommt und probiere mal aus was passiert. Wenn das aber echt Fz spezifisch programmiert werden muss, hab ich mit Plug&Play natürlich schlechte Karten. Vermute, dass es aber auch aus nem Volvo kommt, weil es gibt nicht so viele Prins VSI1 CNG Modelle/Umrüstungen...
     
  11. rix1

    rix1 AutoGasDazugehöriger

    Dabei seit:
    27.02.2021
    Beiträge:
    38
    Zustimmungen:
    10
    Guten Abend zusammen,
    nochmal ein Update: der gebrauchte PTO ist angekommen und ich habe ihn mal direkt angesteckt.
    Die gute Nachricht ist, jetzt habe ich wieder ein RPM Signal am Prins Computer und die CNG Anlage schaltet bei 40°C wie eingestellt um.
    Die schlechte Nachricht ist, der Motor geht dabei jedes mal aus.

    Wenn man während des Umschaltens ordentlich Gas gibt, passiert etwas kurioses: die Drehzahlanzeige im Volvo springt hin und her und landet schlussendlich bei 0 und bewegt sich nicht mehr. Der Motor bleibt jetzt allerdings an, läuft auf CNG und nimmt sauber Gas an.
    In der Bexprins Software wird auch weiterhin die korrekte Drehzahl angezeigt, nur anscheinend leitet das PTO dies nicht mehr an das ECM weiter.
    Als Fehlermeldung im Volvo habe ich wieder "reduzierte Performance" incl. dem bekannten ECM-P033600 Kurbelwellensensorfehler, welcher mich ja fälschlicherweise dazu verleitet hat, den alten Sensor zu tauschen.

    Entweder liegt das Verhalten jetzt an der fehlenden Programmierung oder der gebrauchte PTO hat auch einen Schaden; allerdings leitet er ja Anfangs, vor dem Umschalten auf CNG, das RPM Signal schön an die VSI weiter, im Gegensatz zu meinem ursprünglichen PTO.

    Ich versuche mal Herrm Dallmann und oder Herrn Sommerfeld zu erreichen um das mal durchzusprechen.

    Wenn alles nichts hilft, klemme ich das PTO ab, verbinde den Kurbelwellensensor wieder direkt mit dem ECM und gebe das Einlassnockenwellensignal auf die 40er Leitung. Mal schauen wie er dann läuft...
     
  12. rix1

    rix1 AutoGasDazugehöriger

    Dabei seit:
    27.02.2021
    Beiträge:
    38
    Zustimmungen:
    10
    Guten Abend,
    kurze Rückmeldung meinerseits: Herr Dallmann von EKOGAS in Leipzig hatte mir unkompliziert, schnell und günstig mit der Programmierung der PTOs weitergeholfen. Das "Original-PTO" als auch mein gebrauchtes Ersatz-PTO ging nach Eindhoven zu Prins, wurde nochmal neu programmiert, und ging dann direkt wieder zu mir zurück.
    Hatte das "Original-PTO" nun wieder eingebaut, und zu meinem Erstaunen war nun wieder das RPM Signal da!
    Nach Erreichen von 40°C schaltete die Prins seidenweich auf CNG um (kein Ruckeln oder sonstwas), trotz recht kaltem Motor. Drehzahlanzeige war die ganze Zeit vorhanden.
    Also das ist echt verrückt, war eigentlich sehr sicher, dass das PTO defekt ist.
    Nun ja, jetzt habe ich ein Ersatz-PTO. Schadet nicht. Falls das "Original-PTO" nochmal die Programmierung verliert, wechsle ich permanent auf das andere.

    Also, nochmal vielen Dank an @V8gaser und Herrn Dallmann/EKOGAS
     
    V8gaser gefällt das.
  13. Anzeige

  14. rix1

    rix1 AutoGasDazugehöriger

    Dabei seit:
    27.02.2021
    Beiträge:
    38
    Zustimmungen:
    10
    Guten Abend nochmal,

    ich hatte mich gestern leider zu früh gefreut.
    Als ich heute alles zusammen gebaut hatte und losfahren wollte, ging der Wagen jedes mal beim Gasgeben aus.
    Dabei leuchteten kurz sämtliche Kontrolllampen auf und manchmal kam dann „reduzierte Motorleistung“.
    Habe dann wieder alles auseinander gebaut, und das Ganze mit dem anderen PTO probiert, aber leider ist das Ergebnis das gleiche.
    Das Umschalten funktioniert ohne Probleme, nur wenn man dann über ca. 2000 U/min geht bzw. mal kräftig aufs Gas tritt, kommt o.g. Symptomatik.

    Wenn ich auf Benzin schalte, dann geht das Gasgeben einwandfrei (trotz eingebautem PTO bzw. durchgeschleiftem Kurbelwellensignal).
    Hab mal testweise bis 4000 U/min drehen lassen.

    In Bexprins gibt es keine Fehlermeldung, aber beim Volvo/VIDA habe ich zwei Fehlercodes:
    ECM-P033500 Kurbenwellenpositionssensor (erkennt OT nicht)
    ECM-P061A00 Internal Control Module Torque Performance (angefordertes Drehmoment zu hoch)

    Der erste Fehler ist ja der Altbekannte als das RPM Signal ausfiel.
    Den zweiten Fehler ist mir neu, habe ich bisher noch nicht gehabt.
    In der Beschreibung dazu steht, dass ein „interner Fehler vorläge, der ein höheres als erlaubtes Drehmoment anfordere“.
    Außerdem würden die U/min dann auf 2200 begrenzt werden (Einspritzung wird deaktiviert?)
    Vermutlich ist das dann der Moment, wenn alle Kontrolllampen leuchten und der Motor ausgeht.

    Kann es sein, dass das PTO eben doch das Kurbelwellensignal verändert, und zwar in der Art, dass das ECM jetzt diesen internen Fehler bringt? Bin aktuell etwas ratlos, weil vor dem Ausfall ja alles funktioniert hat.
     
  15. rix1

    rix1 AutoGasDazugehöriger

    Dabei seit:
    27.02.2021
    Beiträge:
    38
    Zustimmungen:
    10
    Guten Abend zusammen,
    will ja hier eigentlich keinen Monolog schreiben, aber es gibt vielleicht ja noch den ein oder anderen Prins VSI 1 CNG Mitleser, für den das hier relevant sein könnte:
    Also, nach Kommunikation und Weiterleitung meines Fehlers von Herrn Dallmann mit Prins in Einhoven, stellte sich heraus, dass bei meiner damaligen Umrüstung (in 2010), das Kurbelwellensignal invertiert angeschlossen wurde.
    D.h. dass eben nicht + auf C3 sowie - auf B3 anliegt, sondern - auf C3 sowie + auf B3. Offenbar war die damalige Software des PTO dann auch darauf ausgerichtet.
    Nun, die neue, aktualisierte Software nutzt jetzt die richtige Pinbelegung, und hat wegen dem "falschen" Eingangssignal dann den oben beschriebenen ECM-P061A00 Fehler erzeugt.
    Die Lösung war daher simpel, einfach die Eingänge B3 mit C3 vertauschen, sowie das gleiche an den Ausgängen (B1 mit C1), damit das Signal auch korrekt zum ECM durchgeschleift wird. Habe das durch Löten & Schrumpfschläuche gelöst, da ich den Stecker selbst nicht öffen konnte/nicht dabei zerstören wollte.

    Habe gerade eine 100km Testfahrt hinter mir, mit hohen Drehzahlen und Vollastbetrieb. Zu keiner Zeit, egal welche Drehzahl und Motorlast, trat irgendein Fehler auf. Fährt sich super, bin sehr zufrieden. (Hatte neben dem PTO noch zahlreiche andere Dinge gewartet/in Stand gesetzt; hatte z.B. leichte Falschluft am Öleinfüllstützen weil die DIchtung komplett hart war, oder zwei Zündspulen saßen komplett locker, Schelle am Niederdruckfilter war leicht undicht.. etc)
    Also scheint ein happy end zu nehmen, hoffe es bleibt jetzt dabei ;)
     
    V8gaser und 540V8 gefällt das.
Thema:

Prins VSI1 CNG Timing Optimizer (PTO) - kein RPM Signal

Die Seite wird geladen...

Prins VSI1 CNG Timing Optimizer (PTO) - kein RPM Signal - Ähnliche Themen

  1. 300c 3.5 V6 Prins VSI1 Shudder and shutoff at idle.

    300c 3.5 V6 Prins VSI1 Shudder and shutoff at idle.: Hi all! My German is not so good, I hope we have some English speaking specialists here. A Chrysler 300C 3.5 V6 with Prins VSI1 runs good on...
  2. Prins VSI1 Plus und Minusleitung

    Prins VSI1 Plus und Minusleitung: Hallo hab einen BMW X5 E53 M54 B30 mit einer Prins VSI1 Anlage. Ich musste leider den Kabelbaum vom Getriebe und Lambdasonde tauschen. Leider war...
  3. Prins VSI1 fällt NUR bei Regen NUR im Schubbetrieb aus

    Prins VSI1 fällt NUR bei Regen NUR im Schubbetrieb aus: Moin, ja wie der Titel schon vermuten lässt, habe ich ein etwas kurioses Problem bei meinem Astra-H Z20LER. Und zwar sobald es regnet - und zwar...
  4. Prins VSI1 Magnetventile schalten immer hin und her

    Prins VSI1 Magnetventile schalten immer hin und her: Magnetventile schalten ein und aus
  5. Prins VSI1 Kabelbaum Pfusch

    Prins VSI1 Kabelbaum Pfusch: Hi, Habe einen Lexus LS400 mit dem 1UZ-FE, der eigentlich unzerstörbar ist, jedoch war mein Ventilspiel absolut nicht in Ordnung. Die Gasanlage...